What did you do to your Fiat lately ?

Discussion about the website and about Fiat-related topics that don't fit in other categories.
User avatar
texanbrit
Posts: 576
Joined: Wed Sep 19, 2018 11:01 pm
Location: Conroe, TX
Your Car's Year / Make / Model: 2013 500c Abarth
Your Instagram (Optional): paul_rogerson_tx
Contact:

Re: What did you do to your Fiat lately ?

Post by texanbrit » Fri Sep 11, 2020 12:30 pm

I don't know about the C514 but for the C510 I have them listed as:
trans bolts.PNG
trans bolts.PNG (73.8 KiB) Viewed 101 times
2013 Abarth 500c (NGen Turbo'd) - Isabella
2012 500 Pop (technically sold) - Popabella
2014 500L (just starting) - The Hulk
1971 850 Sport Spider (what was I thinking) - No name yet

sportfan
Posts: 201
Joined: Thu Sep 20, 2018 11:33 pm
Location: Ponca City, Ok.
Your Car's Year / Make / Model: 2013 Fiat 500 Sport

Re: What did you do to your Fiat lately ?

Post by sportfan » Fri Sep 11, 2020 2:48 pm

The lady never called me back from Tech Authority so I called them. I got a guy that had to repeat ever sentence back to me. When I placed the order on the 31st it didn't work so I ordered it again. Then I got two emails saying I had two manuals coming. So I called them and canceled one order. I told the guy the story and he checked and found out that UPS here had reported the order damaged to the shipper. I asked the guy why didn't somebody get with me about it ? He said that wasn't policy that someone would get in touch with me in 48 hours to talk about it. I told him that they sucked. The new STI with 400 HP is really starting to sound good.

User avatar
MadFiat
Site Admin
Posts: 512
Joined: Wed Sep 19, 2018 10:42 pm
Location: Beaumont, TX
Your Car's Year / Make / Model: 2015 Fiat 500 Abarth
Your Instagram (Optional): madfiat
Xbox ID (Optional): madfiat
Contact:

Re: What did you do to your Fiat lately ?

Post by MadFiat » Sat Sep 12, 2020 11:48 am

Wait I was supposed to torque the trans to engine block bolts? ;)

I just put them at "Meh seems really tight to me" level of torque. And the ones bolting into aluminum slightly less than that.
2015 Rosso Abarth 5MT - MAD FIAT - EC Phase 2 + Supporting Mods
2003 PT Cruiser GT 2.4 Turbo - SALVAGE PT - SOLD to Family
2015 Granito Lucente 500T 6AT - Projecto Estupido

User avatar
texanbrit
Posts: 576
Joined: Wed Sep 19, 2018 11:01 pm
Location: Conroe, TX
Your Car's Year / Make / Model: 2013 500c Abarth
Your Instagram (Optional): paul_rogerson_tx
Contact:

Re: What did you do to your Fiat lately ?

Post by texanbrit » Sat Sep 12, 2020 12:49 pm

MadFiat wrote:
Sat Sep 12, 2020 11:48 am
Wait I was supposed to torque the trans to engine block bolts? ;)

I just put them at "Meh seems really tight to me" level of torque. And the ones bolting into aluminum slightly less than that.
I beleive that's the correct, weights and measures certified, specs. Seems really tight is about 60Nm. OMG it's going to break is about 90Nm. OMG I'm going to break is about 120Nm.
2013 Abarth 500c (NGen Turbo'd) - Isabella
2012 500 Pop (technically sold) - Popabella
2014 500L (just starting) - The Hulk
1971 850 Sport Spider (what was I thinking) - No name yet

sportfan
Posts: 201
Joined: Thu Sep 20, 2018 11:33 pm
Location: Ponca City, Ok.
Your Car's Year / Make / Model: 2013 Fiat 500 Sport

Re: What did you do to your Fiat lately ?

Post by sportfan » Sat Sep 12, 2020 8:21 pm

Thanks Paul, I finally found the specs.

sportfan
Posts: 201
Joined: Thu Sep 20, 2018 11:33 pm
Location: Ponca City, Ok.
Your Car's Year / Make / Model: 2013 Fiat 500 Sport

Re: What did you do to your Fiat lately ?

Post by sportfan » Tue Sep 15, 2020 7:21 pm

Yesterday after three tries we got a service manual to down load. After studying the pictures for a while I figured out my shift cable problem. I couldn't find any text that dealt with my problem. I was getting in and out of the car trying the shifter after some adjustments. Just out of habit I pushed the clutch in. I sure wished the slave cylinder had been bolted down . So after putting the slave cylinder back together I quit for the night. This morning I got my wife to help me bleed the clutch out. So I took it out for about a twenty minute test drive and came back home to check for any leaks but, didn't find any. I do wish I had more pedal pressure on the clutch like before. I might make it to Twisted after all.

Return to “On Topic Discussion”